Troubleshooting

This is a collection of helpful information for frequent problems when using Prism Launcher.

Minecraft 1.16.5 with Minecraft Forge and Java 8u321+

Older versions of Minecraft Forge for Minecraft 1.16.5 cause the game to crash on launch, as they do not support the latest revisions of Java 8.

You can fix this by changing the Forge version in the launcher to the latest or recommended version.
For that go to VersionSelect ForgeChange VersionSelect newest versionOK

Alternatively you can download and use an older Java version (i.e. Java 8u312)

Minecraft Forge failing to run processor

If you are getting an error saying Failed to run processor: java.net.ConnectException: Connection refused when trying to launch a Minecraft Forge instance, you might have connectivity issues with IPv6.

A workaround for this issue is adding the following JVM argument:

-Djava.net.preferIPv4Stack=true

Windows (7, 8.1, 10, 11)

"MSVCP140_2.dll was not found"?

Since Prism Launcher 6.0, Prism is compiled using MSVC on Windows.
As a consequence of this, like most apps on Windows, you have to install vcredist for Prism to run.
You need:

  • vcredist 2022 x64 if you're using PrismLauncher-Windows-MSVC (the reccomended version for Windows 10 64 bit/Windows 11)
  • vcredist 2022 x86 if you're using PrismLauncher-Windows-MSVC-Legacy (the reccomended version for Windows 7/8.1 and Windows 10 32 bit)
  • vcredist 2022 arm64 if you're using PrismLauncher-Windows-MSVC-arm64 (the reccomended version for Windows 10/11 on ARM)

How do I open a .zip file?

Windows by default can "open" .zip archive files, but in order to use Prism Launcher, you will want to extract it instead.

Windows Protected my PC?

This is unfortunately normal behaviour due to the nature of the Windows app signing process. Prism Launcher has yet to purchase a signature, however, with enough funding, we may choose to do so in the future. Prism Launcher is an open-source application. As a result of this, all of the source code is public, and can be audited by any individual or group. If you would like to do so yourself, you can do so here.

If you are comfortable and trust Prism Launcher, then you can click on the More info button, and then do the same on the Run anyway one too.

Windows 7 and 8.1

"api-ms-win-core-synch-l1-2.0.dll not found" or "The procedure entry point CreateDXGIFactory2 could not be located in the dynamic link library dxgi.dll"?

Prism Launcher uses Qt 6 by default on Windows, which does not support Windows 7 and Windows 8.1.

For this reason, we still provide a build that uses Qt 5 in our download page called "Legacy version", you'll have to use that on those legacy versions of Windows.

macOS

macOS cannot verify that this app is free from malware?

Much like the similar pop-up on Windows, this too is normal behaviour.

If you face this obstacle, right-click on Prism Launcher.app, and click Open. Click the Close button on the pop-up window, and then right-click on Prism Launcher.app again. Click on open, and then click on Open once more.

There's also another way to do this: open your Mac's System Preferences application, and make your way to the Security & Privacy page. Once there, near the bottom of the page, there should be an "Open Anyway" option. Click on that option, and then re-open the installer.

Linux

How do I install the Prism Launcher Flatpak on my Linux system?

Detailed instructions on setting-up your system to install Flatpak applications from Flathub, can be found here.

How do I open the Prism Launcher AppImage on my Linux system?

Depending on your system, you may need to grant the Prism Launcher AppImage executable permissions.

You can do this by opening your system's terminal application, making sure to navigate to the location of the downloaded AppImage, before granting the execute permission using this command:

sudo chmod +x PrismLauncher-Linux-8.0-x86_64.AppImage

Please note, that depending on the version of Prism Launcher that you have downloaded, you may have to change the version number in the command above.

If you want to simplify the installation of the AppImage, use AppImageLauncher. Note that this won't work on non-systemd system, and we recommend just using packages.

Prism Launcher isn't using my system theme

Prism Launcher has support for Qt 6.
This means that some themes and theming platforms like KDE Plasma's theming will not work on builds using that version of the Qt toolkit.
But don't worry, we still provide Qt 5 builds.
You can find them on the download page.

Windows and Linux

I want to make my system install portable

On Prism Launcher you can make any install portable (or making portable installs system) just by adding (or removing) portable.txt to the Prism Launcher root directory.


Pages in Overview: